C and Verilog
Here you will find some code for C programing as well as verilog
sábado, 22 de febrero de 2014
TCP Checksum
unsigned short tcp_checksum (int count, unsigned short * addr,unsigned long ip_src,unsigned int ip_dst)
{
unsigned long sum = 0;
unsigned long sum2 = 0;
int k=0;
int count2;
count2=count;
count=count>>8;
// printf("\nCount =%i \n",count);
while (count > 1) {
// printf("\n%04x ",htons(*addr ));
sum += htons(*addr++);
count -= 2;
}
// Add left-over byte, if any
if (count > 0)
sum += * (unsigned char *) htons(addr);
//printf("Pseudoheader\n");
sum += htons(ip_dst) & 0x00ffff;//printf("\n%04x ",htons(ip_dst) );
sum += htons(ip_dst>>16) ; //printf("\n%04x ",htons(ip_dst>>16) );
sum += htons(ip_src) & 0x00ffff; //printf("\n%04x ",htons(ip_src) );
sum += htons(ip_src>>16) ; //printf("\n%04x ",htons(ip_src>>16) );
sum += 0x6; //printf("\n%04x ",0x6 );
sum += htons(pacsize+count2);
//printf("\n%04x ",htons(pacsize+count2));
while (sum >> 16)
sum = (sum & 0xffff) + (sum >> 16);
return (unsigned short )(htons(~sum));
}
unsigned short checksum (int count, unsigned short * addr) {
unsigned long sum = 0;
count=count>>8;
// printf("Count =%x \n",count);
while (count > 1) {
// printf("%x ",(*addr<<8 &0xff00 ));
sum += *addr++;
count -= 2;
}
// Add left-over byte, if any
if (count > 0)
sum += * (unsigned char *) addr;
if (sum >> 16)
sum = (sum & 0xffff) + (sum >> 16);
/*while (sum >> 16)
sum = (sum & 0xffff) + (sum >> 16);*/
return (unsigned short )(~sum);
}
viernes, 7 de febrero de 2014
Read and Write IDE ATA functions in C
The following functions in C allows you to read and write a single sector in a hard disk:
int IDE1=0x1F0;
unsigned int drive=0x00;
int Read_Disk(unsigned long addr, unsigned char *targetbuffer)
{
unsigned int i;
int idx;
unsigned int tmpword;
unsigned char buffer[512];
outb(0x00,IDE1+0x01);//null data
outb(0x1,IDE1+0x02);//sector count
outb((unsigned char) addr,IDE1+0x03 );
outb((unsigned char)(addr >> 8),IDE1+0x04 );
outb((unsigned char)(addr >> 16),IDE1+0x05 );
outb(0xE0 | (drive << 4) | ((addr >> 24) & 0x0F),IDE1+0x06 );
outb( 0x20,IDE1+0x07);
while (!(inb(IDE1+0x07) &0x08)) {
//printf("waiting for HD 0x%x\n",addr);
inb(IDE1+0x07);
}
for (idx = 0; idx < 512; idx++)
{
tmpword = inw(IDE1+0x0);
buffer[idx] = (unsigned char)tmpword;
buffer[idx + 1] = (unsigned char)(tmpword >> 8);
//printf("%hhx %hhx ",(unsigned char)buffer[idx],(unsigned char)buffer[idx+1]);
idx++;
}
memcpy(targetbuffer,&buffer,512);
return idx;
}
int Write_Disk(unsigned long addr, unsigned char *targetbuffer)
{
unsigned int i,drive;
int idx;
int m=0;
drive=0;
unsigned int tmpword;
unsigned char buffer[512];
memcpy(&buffer,targetbuffer,512);
outb(0x00,IDE1+0x1);//null data
outb(0x1,IDE1+0x2);//sector count
outb((unsigned char) addr,IDE1+0x3 );
outb((unsigned char)(addr >> 8),IDE1+0x4);
outb((unsigned char)(addr >> 16),IDE1+0x5 );
outb( 0xE0 | (drive << 4) | ((addr >> 24) & 0x0F),IDE1+0x6);
outb( 0x31,IDE1+0x7);//write command
while ((inb(IDE1+0x7) != 0x58)) {
//printf("Write waiting for HD\n");
}
for (idx = 0; idx < 2*512; idx++)
{
tmpword = buffer[ idx ] | (buffer[ idx + 1] << 8);
outw(tmpword,IDE1+0x0);
idx++;
}
return idx;
}
int IDE1=0x1F0;
unsigned int drive=0x00;
int Read_Disk(unsigned long addr, unsigned char *targetbuffer)
{
unsigned int i;
int idx;
unsigned int tmpword;
unsigned char buffer[512];
outb(0x00,IDE1+0x01);//null data
outb(0x1,IDE1+0x02);//sector count
outb((unsigned char) addr,IDE1+0x03 );
outb((unsigned char)(addr >> 8),IDE1+0x04 );
outb((unsigned char)(addr >> 16),IDE1+0x05 );
outb(0xE0 | (drive << 4) | ((addr >> 24) & 0x0F),IDE1+0x06 );
outb( 0x20,IDE1+0x07);
while (!(inb(IDE1+0x07) &0x08)) {
//printf("waiting for HD 0x%x\n",addr);
inb(IDE1+0x07);
}
for (idx = 0; idx < 512; idx++)
{
tmpword = inw(IDE1+0x0);
buffer[idx] = (unsigned char)tmpword;
buffer[idx + 1] = (unsigned char)(tmpword >> 8);
//printf("%hhx %hhx ",(unsigned char)buffer[idx],(unsigned char)buffer[idx+1]);
idx++;
}
memcpy(targetbuffer,&buffer,512);
return idx;
}
int Write_Disk(unsigned long addr, unsigned char *targetbuffer)
{
unsigned int i,drive;
int idx;
int m=0;
drive=0;
unsigned int tmpword;
unsigned char buffer[512];
memcpy(&buffer,targetbuffer,512);
outb(0x00,IDE1+0x1);//null data
outb(0x1,IDE1+0x2);//sector count
outb((unsigned char) addr,IDE1+0x3 );
outb((unsigned char)(addr >> 8),IDE1+0x4);
outb((unsigned char)(addr >> 16),IDE1+0x5 );
outb( 0xE0 | (drive << 4) | ((addr >> 24) & 0x0F),IDE1+0x6);
outb( 0x31,IDE1+0x7);//write command
while ((inb(IDE1+0x7) != 0x58)) {
//printf("Write waiting for HD\n");
}
for (idx = 0; idx < 2*512; idx++)
{
tmpword = buffer[ idx ] | (buffer[ idx + 1] << 8);
outw(tmpword,IDE1+0x0);
idx++;
}
return idx;
}
miércoles, 1 de enero de 2014
Simple terminal emulator for Linux part 1
This is a simple version of a minicom program.
It is based on: http://www.lafn.org/~dave/linux/Serial-Programming-HOWTO-B.txt
it sends characters to a minicom terminal.
#include <signal.h>
#include <stdio.h> /* Standard input/output definitions */
#include <string.h> /* String function definitions */
#include <unistd.h> /* UNIX standard function definitions */
#include <fcntl.h> /* File control definitions */
#include <errno.h> /* Error number definitions */
#include <termios.h>
#define BAUDRATE B9600
#define MODEMDEVICE "/dev/ttyUSB0"
#define _POSIX_SOURCE 1 /* POSIX compliant source */
#define FALSE 0
#define TRUE 1
// Based on http://www.lafn.org/~dave/linux/Serial-Programming-HOWTO-B.txt
volatile int STOP=FALSE;
struct termios orig_termios;
int main()
{
int fd,c, res;
struct termios oldtio,newtio;
struct termios oldtio2,newtio2;
char buf[255];
char ca;
int r;
unsigned char ch;
fd = open(MODEMDEVICE, O_RDWR | O_NOCTTY );
if (fd <0) {perror(MODEMDEVICE); exit(-1); }
tcgetattr(fd,&oldtio); /* save current port settings */
tcgetattr(0,&oldtio2); /* save current port settings */
bzero(&newtio, sizeof(newtio));
bzero(&newtio2, sizeof(newtio2));
newtio.c_cflag = BAUDRATE | CRTSCTS | CS8 | CLOCAL | CREAD;
newtio.c_iflag = IGNPAR;
newtio.c_oflag = 0;
/* set input mode (non-canonical, no echo,...) */
newtio.c_lflag = 0;
newtio.c_cc[VTIME] = 0; /* inter-character timer unused */
newtio.c_cc[VMIN] = 0; /* blocking read until 5 chars received */
newtio2.c_lflag = 0;
newtio2.c_cc[VTIME] = 0; /* inter-character timer unused */
newtio2.c_cc[VMIN] = 0; /* blocking read until 5 chars received */
tcflush(fd, TCIFLUSH);
tcsetattr(fd,TCSANOW,&newtio);
tcflush(0, TCIFLUSH);
tcsetattr(0,TCSANOW,&newtio2);
while (STOP==FALSE)
{ /* loop for input */
res = read(fd,buf,255); /* returns after 5 chars have been input */
buf[res]=0;
if(res>0)
printf("%s:%d\n", buf, res);
if (buf[0]=='z') STOP=TRUE;
r = read(0, &ch, 1);
if(r>0){
// printf("%c\n", ch, r);
write(fd,&ch,1);
}
}
tcsetattr(fd,TCSANOW,&oldtio);
tcsetattr(0, TCSANOW,&oldtio2);
}
At the moment it needs a "\n" to get the printf working.
code com
It is based on: http://www.lafn.org/~dave/linux/Serial-Programming-HOWTO-B.txt
it sends characters to a minicom terminal.
#include <signal.h>
#include <stdio.h> /* Standard input/output definitions */
#include <string.h> /* String function definitions */
#include <unistd.h> /* UNIX standard function definitions */
#include <fcntl.h> /* File control definitions */
#include <errno.h> /* Error number definitions */
#include <termios.h>
#define BAUDRATE B9600
#define MODEMDEVICE "/dev/ttyUSB0"
#define _POSIX_SOURCE 1 /* POSIX compliant source */
#define FALSE 0
#define TRUE 1
// Based on http://www.lafn.org/~dave/linux/Serial-Programming-HOWTO-B.txt
volatile int STOP=FALSE;
struct termios orig_termios;
int main()
{
int fd,c, res;
struct termios oldtio,newtio;
struct termios oldtio2,newtio2;
char buf[255];
char ca;
int r;
unsigned char ch;
fd = open(MODEMDEVICE, O_RDWR | O_NOCTTY );
if (fd <0) {perror(MODEMDEVICE); exit(-1); }
tcgetattr(fd,&oldtio); /* save current port settings */
tcgetattr(0,&oldtio2); /* save current port settings */
bzero(&newtio, sizeof(newtio));
bzero(&newtio2, sizeof(newtio2));
newtio.c_cflag = BAUDRATE | CRTSCTS | CS8 | CLOCAL | CREAD;
newtio.c_iflag = IGNPAR;
newtio.c_oflag = 0;
/* set input mode (non-canonical, no echo,...) */
newtio.c_lflag = 0;
newtio.c_cc[VTIME] = 0; /* inter-character timer unused */
newtio.c_cc[VMIN] = 0; /* blocking read until 5 chars received */
newtio2.c_lflag = 0;
newtio2.c_cc[VTIME] = 0; /* inter-character timer unused */
newtio2.c_cc[VMIN] = 0; /* blocking read until 5 chars received */
tcflush(fd, TCIFLUSH);
tcsetattr(fd,TCSANOW,&newtio);
tcflush(0, TCIFLUSH);
tcsetattr(0,TCSANOW,&newtio2);
while (STOP==FALSE)
{ /* loop for input */
res = read(fd,buf,255); /* returns after 5 chars have been input */
buf[res]=0;
if(res>0)
printf("%s:%d\n", buf, res);
if (buf[0]=='z') STOP=TRUE;
r = read(0, &ch, 1);
if(r>0){
// printf("%c\n", ch, r);
write(fd,&ch,1);
}
}
tcsetattr(fd,TCSANOW,&oldtio);
tcsetattr(0, TCSANOW,&oldtio2);
}
At the moment it needs a "\n" to get the printf working.
code com
lunes, 30 de diciembre de 2013
SLIP connection between two linux boxes
Well. Assuming that you have serial ports in you linux PC use this command:
slattach /dev/ttyUSB0 -p slip -s 115200 -dL &
linux-edfh:/home/ghgv/Escritorio #
slattach: tty_open: looking for lock
slattach: tty_open: trying to open /dev/ttyUSB0
slattach: tty_open: /dev/ttyUSB0 (fd=3) slattach: tty_set_speed: 115200
slattach: tty_set_databits: 8
slattach: tty_set_stopbits: 1
slattach: tty_set_parity: N
slip started on /dev/ttyUSB0 interface sl0
this will create a sl0 interface that you will assign an ip address so:
ifconfig sl0 192.168.4.3/24
linux-edfh:/home/ghgv/Escritorio # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.113 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10657 errors:0 dropped:7 overruns:0 frame:0
TX packets:8060 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12578920 (11.9 Mb) TX bytes:1208599 (1.1 Mb)
Interrupt:40
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:44 dropped:0 overruns:0 carrier:86
collisions:731 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:10609 (10.3 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2931 errors:0 dropped:0 overruns:0 frame:0
TX packets:2931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:224671 (219.4 Kb) TX bytes:224671 (219.4 Kb)
linux-edfh:/home/ghgv/Escritorio # ifconfig sl0 192.168.4.3/24
linux-edfh:/home/ghgv/Escritorio # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.113 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10728 errors:0 dropped:7 overruns:0 frame:0
TX packets:8153 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12604199 (12.0 Mb) TX bytes:1224701 (1.1 Mb)
Interrupt:40
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:44 dropped:0 overruns:0 carrier:86
collisions:731 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:10609 (10.3 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2931 errors:0 dropped:0 overruns:0 frame:0
TX packets:2931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:224671 (219.4 Kb) TX bytes:224671 (219.4 Kb)
sl0 Link encap:Serial Line IP
inet addr:192.168.4.3 P-t-P:192.168.4.3 Mask:255.255.255.0
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:296 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
linux-edfh:/home/ghgv/Escritorio #
In the other PC, you need to do the same:
linux-edfh:/home/ghgv/Escritorio # telnet 192.168.1.111
Trying 192.168.1.111...
Connected to 192.168.1.111.
Escape character is '^]'.
Welcome to openSUSE 12.1 "Asparagus" - Kernel 3.1.0-1.2-desktop (0).
linux-mqeo login: ghgv
Contraseña:
Último inicio de sesión:lun dic 30 18:51:31 COT 2013de consoleen :0
Have a lot of fun...
Directory: /home/ghgv
lun dic 30 18:52:50 COT 2013
ghgv@linux-mqeo:~> su
Contraseña:
linux-mqeo:/home/ghgv # slattach /dev/ttyUSB0 -p slip -s 115200 -dL &
[1] 6635
linux-mqeo:/home/ghgv # slattach: tty_open: looking for lock
slattach: tty_open: trying to open /dev/ttyUSB0
slattach: tty_open: /dev/ttyUSB0 (fd=3) slattach: tty_set_speed: 115200
slattach: tty_set_databits: 8
slattach: tty_set_stopbits: 1
slattach: tty_set_parity: N
slip started on /dev/ttyUSB0 interface sl0
linux-mqeo:/home/ghgv # ifconfig sl0 192.168.4.4/24
linux-mqeo:/home/ghgv # ifconfig
eth0 Link encap:Ethernet HWaddr 00:24:8C:73:EF:9B
inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::224:8cff:fe73:ef9b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:202 errors:0 dropped:1 overruns:0 frame:0
TX packets:131 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18947 (18.5 Kb) TX bytes:15945 (15.5 Kb)
Interrupt:41 Base address:0x2000
eth1 Link encap:Ethernet HWaddr 00:E0:7D:89:C9:9C
inet addr:192.168.3.3 Bcast:192.168.3.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:21 Base address:0x8c00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3959 (3.8 Kb) TX bytes:3959 (3.8 Kb)
sl0 Link encap:Serial Line IP
inet addr:192.168.4.4 P-t-P:192.168.4.4 Mask:255.255.255.0
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:296 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
wlan0 Link encap:Ethernet HWaddr 00:11:D8:B7:D6:67
inet addr:192.168.1.111 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:feb7:d667/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:41 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4453 (4.3 Kb) TX bytes:7683 (7.5 Kb)
linux-mqeo:/home/ghgv #
from the initial PC
linux-edfh:/home/ghgv/Escritorio # ping 192.168.4.4
PING 192.168.4.4 (192.168.4.4) 56(84) bytes of data.
64 bytes from 192.168.4.4: icmp_seq=1 ttl=64 time=18.3 ms
64 bytes from 192.168.4.4: icmp_seq=2 ttl=64 time=18.7 ms
64 bytes from 192.168.4.4: icmp_seq=3 ttl=64 time=18.7 ms
^C
--- 192.168.4.4 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 18.350/18.627/18.778/0.225 ms
slattach /dev/ttyUSB0 -p slip -s 115200 -dL &
linux-edfh:/home/ghgv/Escritorio #
slattach: tty_open: looking for lock
slattach: tty_open: trying to open /dev/ttyUSB0
slattach: tty_open: /dev/ttyUSB0 (fd=3) slattach: tty_set_speed: 115200
slattach: tty_set_databits: 8
slattach: tty_set_stopbits: 1
slattach: tty_set_parity: N
slip started on /dev/ttyUSB0 interface sl0
this will create a sl0 interface that you will assign an ip address so:
ifconfig sl0 192.168.4.3/24
linux-edfh:/home/ghgv/Escritorio # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.113 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10657 errors:0 dropped:7 overruns:0 frame:0
TX packets:8060 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12578920 (11.9 Mb) TX bytes:1208599 (1.1 Mb)
Interrupt:40
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:44 dropped:0 overruns:0 carrier:86
collisions:731 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:10609 (10.3 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2931 errors:0 dropped:0 overruns:0 frame:0
TX packets:2931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:224671 (219.4 Kb) TX bytes:224671 (219.4 Kb)
linux-edfh:/home/ghgv/Escritorio # ifconfig sl0 192.168.4.3/24
linux-edfh:/home/ghgv/Escritorio # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.113 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10728 errors:0 dropped:7 overruns:0 frame:0
TX packets:8153 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12604199 (12.0 Mb) TX bytes:1224701 (1.1 Mb)
Interrupt:40
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:44 dropped:0 overruns:0 carrier:86
collisions:731 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:10609 (10.3 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2931 errors:0 dropped:0 overruns:0 frame:0
TX packets:2931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:224671 (219.4 Kb) TX bytes:224671 (219.4 Kb)
sl0 Link encap:Serial Line IP
inet addr:192.168.4.3 P-t-P:192.168.4.3 Mask:255.255.255.0
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:296 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
linux-edfh:/home/ghgv/Escritorio #
In the other PC, you need to do the same:
linux-edfh:/home/ghgv/Escritorio # telnet 192.168.1.111
Trying 192.168.1.111...
Connected to 192.168.1.111.
Escape character is '^]'.
Welcome to openSUSE 12.1 "Asparagus" - Kernel 3.1.0-1.2-desktop (0).
linux-mqeo login: ghgv
Contraseña:
Último inicio de sesión:lun dic 30 18:51:31 COT 2013de consoleen :0
Have a lot of fun...
Directory: /home/ghgv
lun dic 30 18:52:50 COT 2013
ghgv@linux-mqeo:~> su
Contraseña:
linux-mqeo:/home/ghgv # slattach /dev/ttyUSB0 -p slip -s 115200 -dL &
[1] 6635
linux-mqeo:/home/ghgv # slattach: tty_open: looking for lock
slattach: tty_open: trying to open /dev/ttyUSB0
slattach: tty_open: /dev/ttyUSB0 (fd=3) slattach: tty_set_speed: 115200
slattach: tty_set_databits: 8
slattach: tty_set_stopbits: 1
slattach: tty_set_parity: N
slip started on /dev/ttyUSB0 interface sl0
linux-mqeo:/home/ghgv # ifconfig sl0 192.168.4.4/24
linux-mqeo:/home/ghgv # ifconfig
eth0 Link encap:Ethernet HWaddr 00:24:8C:73:EF:9B
inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::224:8cff:fe73:ef9b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:202 errors:0 dropped:1 overruns:0 frame:0
TX packets:131 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18947 (18.5 Kb) TX bytes:15945 (15.5 Kb)
Interrupt:41 Base address:0x2000
eth1 Link encap:Ethernet HWaddr 00:E0:7D:89:C9:9C
inet addr:192.168.3.3 Bcast:192.168.3.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:21 Base address:0x8c00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3959 (3.8 Kb) TX bytes:3959 (3.8 Kb)
sl0 Link encap:Serial Line IP
inet addr:192.168.4.4 P-t-P:192.168.4.4 Mask:255.255.255.0
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:296 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
wlan0 Link encap:Ethernet HWaddr 00:11:D8:B7:D6:67
inet addr:192.168.1.111 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:feb7:d667/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:41 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4453 (4.3 Kb) TX bytes:7683 (7.5 Kb)
linux-mqeo:/home/ghgv #
from the initial PC
linux-edfh:/home/ghgv/Escritorio # ping 192.168.4.4
PING 192.168.4.4 (192.168.4.4) 56(84) bytes of data.
64 bytes from 192.168.4.4: icmp_seq=1 ttl=64 time=18.3 ms
64 bytes from 192.168.4.4: icmp_seq=2 ttl=64 time=18.7 ms
64 bytes from 192.168.4.4: icmp_seq=3 ttl=64 time=18.7 ms
^C
--- 192.168.4.4 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 18.350/18.627/18.778/0.225 ms
There is no layer 2 information!!. No MAC addresses and the IP needs to be known for the SLIP to work
domingo, 8 de diciembre de 2013
Writing bytes from a NE2000 ethernet card part 1
Hi.
Well, today we will write some bytes in a ethernet network. We will use a NE2000 lan card. I hope you still have one.
Documentation needed for this is:
Writing Drivers for the
DP8390 NIC Family of
Ethernet Controllers
Well, today we will write some bytes in a ethernet network. We will use a NE2000 lan card. I hope you still have one.
Documentation needed for this is:
Writing Drivers for the
DP8390 NIC Family of
Ethernet Controllers
From National Semiconductor.
My PCI card is in 0xbf00 as base address. You might need to know the base address of your card. Some are 0x300.
Compile with gcc -O -o testne2000 testne2000.c kbhit.c
testne2000.c:
#include <unistd.h>
#include <stdio.h>
#include <stdlib.h>
#include <sys/mman.h>
#include <sys/stat.h>
#include <fcntl.h>
#include <getopt.h>
#if defined(__linux__) && __GNU_LIBRARY__ == 1
#include <asm/io.h>
#else
#include <sys/io.h>
#endif
#if !defined(__OPTIMIZE__)
#error You must compile this driver with "-O"!
#endif
#define COMMAND 0xbf00
#define DATACONFIGURATION COMMAND+0x0E
#define COMMAND 0xbf00
#define PAGESTART COMMAND+01
#define PAGESTOP COMMAND+02
#define BOUNDARY COMMAND+03
#define TRANSMITSTATUS COMMAND+04
#define TRANSMITPAGE COMMAND+04
#define TRANSMITBYTECOUNT0 COMMAND+0x05
#define NCR COMMAND+05
#define TRANSMITBYTECOUNT1 COMMAND+0x06
#define INTERRUPTSTATUS COMMAND+0x07
#define CURRENT COMMAND+07
#define REMOTESTARTADDRESS0 COMMAND+0x08
#define CRDMA0 COMMAND+0x08
#define REMOTESTARTADDRESS1 COMMAND+0x09
#define CRDMA1 COMMAND+0x09
#define REMOTEBYTECOUNT0 COMMAND+0x0A
#define REMOTEBYTECOUNT1 COMMAND+0x0B
#define RECEIVESTATUS COMMAND+0x0C
#define RECEIVECONFIGURATION COMMAND+0x0C
#define TRANSMITCONFIGURATION COMMAND+0x0D
#define FAE TALLY COMMAND+0x0D
#define DATACONFIGURATION COMMAND+0x0E
#define CRC TALLY COMMAND+0x0E
#define INTERRUPTMASK COMMAND+0x0F
#define MISS PKT TALLY COMMAND+0x0F
#define IOPORT COMMAND+0x10
#define PSTART 0x46
#define PSTOP 0x80
#define TRANSMITBUFFER 0x40
#define NE_P1_PAR0 0x01 // Physical Address Register 0
#define NE_P1_PAR1 0x02 // Physical Address Register 1
#define NE_P1_PAR2 0x03 // Physical Address Register 2
#define NE_P1_PAR3 0x04 // Physical Address Register 3
#define NE_P1_PAR4 0x05 // Physical Address Register 4
#define NE_P1_PAR5 0x06 // Physical Address Register 5
#define NE_P1_CURR 0x07 // Current RX ring-buffer page
#define NE_P1_MAR0 0x08 // Multicast Address Register 0
#define NE_P1_MAR1 0x09 // Multicast Address Register 1
#define NE_P1_MAR2 0x0A // Multicast Address Register 2
#define NE_P1_MAR3 0x0B // Multicast Address Register 3
#define NE_P1_MAR4 0x0C // Multicast Address Register 4
#define NE_P1_MAR5 0x0D // Multicast Address Register 5
#define NE_P1_MAR6 0x0E // Multicast Address Register 6
#define NE_P1_MAR7 0x0F // Multicast Address Register 7
#define ETHER_ADDR_LEN 6
struct ether_addr {
unsigned short addr[ETHER_ADDR_LEN];
};
struct ne {
//dev_t devno; // Device number
struct ether_addr hwaddr; // MAC address
unsigned short iobase; // Configured I/O base
unsigned short irq; // Configured IRQ
unsigned short membase; // Configured memory base
unsigned short memsize; // Configured memory size
unsigned short asic_addr; // ASIC I/O bus address
unsigned short nic_addr; // NIC (DP8390) I/O bus address
//struct interrupt intr; // Interrupt object for driver
//struct dpc dpc; // DPC for driver
unsigned short rx_ring_start; // Start address of receive ring
unsigned short rx_ring_end; // End address of receive ring
unsigned char rx_page_start; // Start of receive ring
unsigned char rx_page_stop; // End of receive ring
unsigned char next_pkt; // Next unread received packet
//struct event rdc; // Remote DMA completed event
//struct event ptx; // Packet transmitted event
//struct mutex txlock; // Transmit lock
};
static int ne_probe(struct ne *ne) {
unsigned char byte,i;
// Reset
//msleep(5000);
byte=inb(0xbf00);
outb(0x21,0xbf00);
// sleep(1);
printf("Command reg %x\n",byte);
outb(0x58,DATACONFIGURATION);
outb(0x00,REMOTEBYTECOUNT0);
outb(0x00,REMOTEBYTECOUNT1);
outb(0x00,RECEIVECONFIGURATION);
outb(0x20,TRANSMITPAGE);
outb(0x02,TRANSMITCONFIGURATION);
outb(0x26,PAGESTART);
outb(0x26,BOUNDARY);
outb(0x40,PAGESTOP);
outb(0x61,COMMAND);
for (i = 0; i < 6; i++)
{
outb(ne->hwaddr.addr[i],COMMAND + NE_P1_PAR0 + i);
}
for (i = 0; i < ETHER_ADDR_LEN; i++)
{
printf("PAR %x %x\n",inb(COMMAND + NE_P1_PAR0 + i),ne->hwaddr.addr[i]);
}
// Actually the ethernet address is overwritten later on wit 0xA5A5. You can fix it. I will put a useful payload later
outb(0x26,CURRENT);
outb(0x22,COMMAND);
outb(0xff,INTERRUPTSTATUS);
outb(0x0B,INTERRUPTMASK);
outb(0x00,TRANSMITCONFIGURATION);
//send a packet
int count =100;
outb(count & 0xff,REMOTEBYTECOUNT0);
outb(count >>8 , REMOTEBYTECOUNT1);
outb(0x00, REMOTESTARTADDRESS0);
outb(TRANSMITBUFFER, REMOTESTARTADDRESS1);
outb(0x12,COMMAND);
for (i=0;i<100;i++)
outw(0xA5A5,IOPORT);
int s=0;
s=inb(INTERRUPTSTATUS);
while(s!=0x40)
s=inb(INTERRUPTSTATUS);
printf("Interrup status %x\n",s);
outb(0x40,INTERRUPTSTATUS);
s=inb(INTERRUPTSTATUS);
printf("Interrup status %x\n",s);
outb(TRANSMITBUFFER,TRANSMITPAGE);
outb(count & 0xff,TRANSMITBYTECOUNT0);
outb(count >>8 ,TRANSMITBYTECOUNT1);
outb(0x26,COMMAND);
return 1;
}
int main(char argc, char **argv)
{
if (iopl(3)) {perror("iopl error"); exit(1);}
struct ne *NIC;
NIC = (struct ne *) malloc(sizeof(struct ne));
NIC->hwaddr.addr[0]=0x00;
NIC->hwaddr.addr[1]=0xA0;
NIC->hwaddr.addr[2]=0xFF;
NIC->hwaddr.addr[3]=0xFF;
NIC->hwaddr.addr[4]=0x58;
NIC->hwaddr.addr[5]=0x33;
int i;
ne_probe(NIC);
return 0;
}
The getch and hitkb are not mine: (those are turboc things I guess)
kbhit.c
#include "kbhit.h"
#include <termios.h>
#include <unistd.h> // for read()
static struct termios initial_settings, new_settings;
static int peek_character = -1;
void init_keyboard()
{
tcgetattr(0,&initial_settings);
new_settings = initial_settings;
new_settings.c_lflag &= ~ICANON;
new_settings.c_lflag &= ~ECHO;
new_settings.c_lflag &= ~ISIG;
new_settings.c_cc[VMIN] = 1;
new_settings.c_cc[VTIME] = 0;
tcsetattr(0, TCSANOW, &new_settings);
}
void close_keyboard()
{
tcsetattr(0, TCSANOW, &initial_settings);
}
int kbhit()
{
unsigned char ch;
int nread;
if (peek_character != -1) return 1;
new_settings.c_cc[VMIN]=0;
tcsetattr(0, TCSANOW, &new_settings);
nread = read(0,&ch,1);
new_settings.c_cc[VMIN]=1;
tcsetattr(0, TCSANOW, &new_settings);
if(nread == 1)
{
peek_character = ch;
return 1;
}
return 0;
}
int readch()
{
char ch;
if(peek_character != -1)
{
ch = peek_character;
peek_character = -1;
return ch;
}
read(0,&ch,1);
return ch;
}
int getch()
{
char ch;
if(peek_character != -1)
{
ch = peek_character;
peek_character = -1;
return ch;
}
read(0,&ch,1);
return ch;
}
The kbhit.n
#ifndef KBHIT_H
#define KBHIT_H
void init_keyboard(void);
void close_keyboard(void);
int kbhit(void);
int readch(void);
int getch(void);
#endif
The frame cannot be captured with wireshark because it is being written directly to the hardware!.
I will also clean up the code later.
Check the screenshoot.
domingo, 10 de noviembre de 2013
Talking to a router in RIP version 1 using a C program in linux part 2
Ok. I updated the programs so that it finally works.
You need to setup a permission to be able to broadcast a RIP packet (255.255.255.255 address as destination).
int optval = 1;
int broadcastEnable=1;
if (setsockopt(s, SOL_SOCKET, SO_BROADCAST, &optval, sizeof(broadcastEnable))
< 0)
perror ("BROADCAST");
You also need to align the structs so that the required frame will output frame.
I created these two strcuts that will go after the UDP part:
typedef struct {
long ip;
long pad;
long pad2;
long metric;
}__attribute__((packed, aligned(1))) route_t;
typedef struct {
char cmd;
char version;
short pad;
short addrFamily;
short pad2;
route_t routes;
} __attribute__((packed, aligned(1))) rip_t;
The way to align them is this __attribute__((packed, aligned(1))) ;
Also the command line is like this: ./rawudp 1.1.1.1 1 The entry you want to use and the metric.
The checksum is defaulted to zero. It means it is disabled.
The RIP frame is available in the page 18 of : http://www.ietf.org/rfc/rfc1058.txt
/*
Code also from Gabriel Serme
*/
#include <sys/socket.h>
#include <sys/types.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>
#include <netinet/udp.h>
#include <arpa/inet.h>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define LEN 512
typedef unsigned short u16;
typedef unsigned long u32;
typedef struct {
long ip;
long pad;
long pad2;
long metric;
}__attribute__((packed, aligned(1))) route_t;
typedef struct {
char cmd;
char version;
short pad;
short addrFamily;
short pad2;
route_t routes;
} __attribute__((packed, aligned(1))) rip_t;
unsigned short csum (unsigned short *buf, int nwords);
int main(int argc, char * argv[])
{
if(argc != 3)
{
printf("- Usage %s <IP > <metric> \n", argv[0]);
exit(1);
}else{
printf ("Arguments : \n"
"\tip : %s\n"
"\tmetric : %s\n",
argv[1], argv[2]);
}
int PSOURCE = 520;
int PDEST = 520;
char *IPADDR = argv[1];
char *METRIC = argv[2];
int s;
rip_t *rip_route=malloc(sizeof(rip_t));
route_t route1,route2;
struct sockaddr_in daddr, saddr, answerip;
char packet[LEN];
/* point the iphdr to the beginning of the packet */
struct iphdr *ip = (struct iphdr *)packet;
struct udphdr *udp = (struct udphdr *)((void *) ip + sizeof(struct iphdr));
struct dnshdr *dns = (struct dnshdr *)((void *) udp + sizeof(struct udphdr));
if ((s = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)) < 0) {
perror("error:");
exit(EXIT_FAILURE);
}
daddr.sin_family = AF_INET;
saddr.sin_family = AF_INET;
daddr.sin_port = htons(520);
saddr.sin_port = htons(520);
saddr.sin_addr.s_addr=inet_addr("192.168.1.104");
daddr.sin_addr.s_addr=inet_addr("192.168.1.105");
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
//inet_pton(AF_INET, DEST, (struct in_addr *)&daddr.sin_addr);
ip->ihl = 5; //header length
ip->version = 4;
ip->tos = 0x0;
ip->id = htons(31337 + (rand()%100));;
ip->frag_off = 0; /* No fragmentattion */
ip->ttl = 255; /* default value */
ip->protocol = 17; //IPPROTO_RAW; /* protocol at L4 */
ip->check = 0; /* not needed in iphdr */
ip->saddr = saddr.sin_addr.s_addr;
ip->daddr = daddr.sin_addr.s_addr;
udp->source = htons(PSOURCE);
udp->dest = htons (PDEST);
route1.ip=inet_addr(IPADDR);
route1.pad=0;
route1.pad2=0;
route1.metric=htonl(atoi(METRIC));
//http://www.ietf.org/rfc/rfc1058.txt page 18
rip_route->cmd=2;
rip_route->version=1;
rip_route->pad=0;
rip_route->addrFamily=htons(AF_INET);
rip_route->pad2=0;
rip_route->routes=route1;
int sizedata = sizeof(rip_t);
memcpy(((void *) udp) + sizeof(struct udphdr), rip_route, sizedata);
int sizeudpdata = sizeof(struct udphdr) + sizedata;
ip->tot_len = htons(sizeudpdata + sizeof(struct iphdr)); /* 16 byte value */
udp->len = htons(sizeudpdata);
udp->check = 0;
int optval = 1;
int broadcastEnable=1;
if (setsockopt(s, SOL_SOCKET, SO_BROADCAST, &optval, sizeof(broadcastEnable))
< 0)
perror ("BROADCAST");
int sizepacket = sizeof(struct iphdr) + sizeudpdata;
if (sendto(s, (char *)packet, sizepacket, 0, (struct sockaddr *)&daddr, (socklen_t)sizeof(daddr)) < 0)
perror("packet send error:");
else
printf("Sent packet\n");
exit(EXIT_SUCCESS);
}
/* Not my code */
unsigned short csum (unsigned short *buf, int nwords)
{
unsigned long sum;
for (sum = 0; nwords > 0; nwords--)
sum += *buf++;
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >> 16);
return ~sum;
}
I changed my ip addresses. The router config is like this:
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
no ip split-horizon
!
interface Ethernet0
ip address 192.168.1.105 255.255.255.0
!
interface Ethernet1
ip address 1.2.3.4 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
router rip
version 1
no validate-update-source
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
Running the program: ./rawudp 1.1.1.1 1
You need to setup a permission to be able to broadcast a RIP packet (255.255.255.255 address as destination).
int optval = 1;
int broadcastEnable=1;
if (setsockopt(s, SOL_SOCKET, SO_BROADCAST, &optval, sizeof(broadcastEnable))
< 0)
perror ("BROADCAST");
You also need to align the structs so that the required frame will output frame.
I created these two strcuts that will go after the UDP part:
typedef struct {
long ip;
long pad;
long pad2;
long metric;
}__attribute__((packed, aligned(1))) route_t;
typedef struct {
char cmd;
char version;
short pad;
short addrFamily;
short pad2;
route_t routes;
} __attribute__((packed, aligned(1))) rip_t;
The way to align them is this __attribute__((packed, aligned(1))) ;
Also the command line is like this: ./rawudp 1.1.1.1 1 The entry you want to use and the metric.
The checksum is defaulted to zero. It means it is disabled.
The RIP frame is available in the page 18 of : http://www.ietf.org/rfc/rfc1058.txt
/*
Code also from Gabriel Serme
*/
#include <sys/socket.h>
#include <sys/types.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>
#include <netinet/udp.h>
#include <arpa/inet.h>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define LEN 512
typedef unsigned short u16;
typedef unsigned long u32;
typedef struct {
long ip;
long pad;
long pad2;
long metric;
}__attribute__((packed, aligned(1))) route_t;
typedef struct {
char cmd;
char version;
short pad;
short addrFamily;
short pad2;
route_t routes;
} __attribute__((packed, aligned(1))) rip_t;
unsigned short csum (unsigned short *buf, int nwords);
int main(int argc, char * argv[])
{
if(argc != 3)
{
printf("- Usage %s <IP > <metric> \n", argv[0]);
exit(1);
}else{
printf ("Arguments : \n"
"\tip : %s\n"
"\tmetric : %s\n",
argv[1], argv[2]);
}
int PSOURCE = 520;
int PDEST = 520;
char *IPADDR = argv[1];
char *METRIC = argv[2];
int s;
rip_t *rip_route=malloc(sizeof(rip_t));
route_t route1,route2;
struct sockaddr_in daddr, saddr, answerip;
char packet[LEN];
/* point the iphdr to the beginning of the packet */
struct iphdr *ip = (struct iphdr *)packet;
struct udphdr *udp = (struct udphdr *)((void *) ip + sizeof(struct iphdr));
struct dnshdr *dns = (struct dnshdr *)((void *) udp + sizeof(struct udphdr));
if ((s = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)) < 0) {
perror("error:");
exit(EXIT_FAILURE);
}
daddr.sin_family = AF_INET;
saddr.sin_family = AF_INET;
daddr.sin_port = htons(520);
saddr.sin_port = htons(520);
saddr.sin_addr.s_addr=inet_addr("192.168.1.104");
daddr.sin_addr.s_addr=inet_addr("192.168.1.105");
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
//inet_pton(AF_INET, DEST, (struct in_addr *)&daddr.sin_addr);
ip->ihl = 5; //header length
ip->version = 4;
ip->tos = 0x0;
ip->id = htons(31337 + (rand()%100));;
ip->frag_off = 0; /* No fragmentattion */
ip->ttl = 255; /* default value */
ip->protocol = 17; //IPPROTO_RAW; /* protocol at L4 */
ip->check = 0; /* not needed in iphdr */
ip->saddr = saddr.sin_addr.s_addr;
ip->daddr = daddr.sin_addr.s_addr;
udp->source = htons(PSOURCE);
udp->dest = htons (PDEST);
route1.ip=inet_addr(IPADDR);
route1.pad=0;
route1.pad2=0;
route1.metric=htonl(atoi(METRIC));
//http://www.ietf.org/rfc/rfc1058.txt page 18
rip_route->cmd=2;
rip_route->version=1;
rip_route->pad=0;
rip_route->addrFamily=htons(AF_INET);
rip_route->pad2=0;
rip_route->routes=route1;
int sizedata = sizeof(rip_t);
memcpy(((void *) udp) + sizeof(struct udphdr), rip_route, sizedata);
int sizeudpdata = sizeof(struct udphdr) + sizedata;
ip->tot_len = htons(sizeudpdata + sizeof(struct iphdr)); /* 16 byte value */
udp->len = htons(sizeudpdata);
udp->check = 0;
int optval = 1;
int broadcastEnable=1;
if (setsockopt(s, SOL_SOCKET, SO_BROADCAST, &optval, sizeof(broadcastEnable))
< 0)
perror ("BROADCAST");
int sizepacket = sizeof(struct iphdr) + sizeudpdata;
if (sendto(s, (char *)packet, sizepacket, 0, (struct sockaddr *)&daddr, (socklen_t)sizeof(daddr)) < 0)
perror("packet send error:");
else
printf("Sent packet\n");
exit(EXIT_SUCCESS);
}
/* Not my code */
unsigned short csum (unsigned short *buf, int nwords)
{
unsigned long sum;
for (sum = 0; nwords > 0; nwords--)
sum += *buf++;
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >> 16);
return ~sum;
}
I changed my ip addresses. The router config is like this:
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
no ip split-horizon
!
interface Ethernet0
ip address 192.168.1.105 255.255.255.0
!
interface Ethernet1
ip address 1.2.3.4 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
router rip
version 1
no validate-update-source
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
Running the program: ./rawudp 1.1.1.1 1
Will produce:
05:23:27: RIP: received v1 update from 192.168.1.104 on Ethernet0
05:23:27: 1.1.1.1 in 1 hops
05:23:30: RIP: sending v1 update to 255.255.255.255 via Ethernet0 (192.168.1.10)
05:23:30: RIP: build update entries
05:23:30: network 1.0.0.0 metric 2
05:23:30: network 10.0.0.0 metric 1
You need to do a
Router#debug ip rip
RIP protocol debugging is on
viernes, 1 de noviembre de 2013
Talking to a router in RIP version 1 using a C program in linux part 1
This time I have a small router with the following config down below. What we will do is to have a linux machine talking RIPv1 to a router. It is a Cisco 2500 in 12.1.
Router#sh ru
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable password yourpassword
!
!
!
!
!
ip subnet-zero
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
no ip split-horizon
!
interface Ethernet0
ip address 192.168.2.2 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
router rip
version 1
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password yourpassword
login
!
end
The router is having RIP and a 192.168.2.0 net in that process.
The linux machine is configure this way:
linux-edfh:/home/ghgv/Escritorio/programs # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:103049 errors:0 dropped:75 overruns:0 frame:0
TX packets:77727 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:119197344 (113.6 Mb) TX bytes:10324905 (9.8 Mb)
Interrupt:42
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:57 errors:0 dropped:13 overruns:0 frame:0
TX packets:185 errors:1518 dropped:0 overruns:0 carrier:3036
collisions:25806 txqueuelen:1000
RX bytes:7446 (7.2 Kb) TX bytes:559247 (546.1 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:27 errors:0 dropped:0 overruns:0 frame:0
TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3711 (3.6 Kb) TX bytes:3711 (3.6 Kb)
The router is connecting to the eth1 as they are in the same network.
Make sure you can ping to each other.
ghgv@linux-edfh:~/Escritorio/programs> ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=64 time=0.045 ms
64 bytes from 192.168.2.1: icmp_seq=2 ttl=64 time=0.035 ms
^C
--- 192.168.2.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.035/0.040/0.045/0.005 ms
ghgv@linux-edfh:~/Escritorio/programs> ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
64 bytes from 192.168.2.2: icmp_seq=1 ttl=255 time=4.82 ms
64 bytes from 192.168.2.2: icmp_seq=2 ttl=255 time=2.31 ms
64 bytes from 192.168.2.2: icmp_seq=3 ttl=255 time=2.35 ms
^Z
[1]+ Detenido ping 192.168.2.2
Router#sh ru
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable password yourpassword
!
!
!
!
!
ip subnet-zero
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
no ip split-horizon
!
interface Ethernet0
ip address 192.168.2.2 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
router rip
version 1
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password yourpassword
login
!
end
The router is having RIP and a 192.168.2.0 net in that process.
The linux machine is configure this way:
linux-edfh:/home/ghgv/Escritorio/programs # ifconfig
eth0 Link encap:Ethernet HWaddr 90:2B:34:9B:28:F8
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe9b:28f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:103049 errors:0 dropped:75 overruns:0 frame:0
TX packets:77727 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:119197344 (113.6 Mb) TX bytes:10324905 (9.8 Mb)
Interrupt:42
eth1 Link encap:Ethernet HWaddr 00:A0:FF:FF:58:33
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:ffff:feff:5833/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:57 errors:0 dropped:13 overruns:0 frame:0
TX packets:185 errors:1518 dropped:0 overruns:0 carrier:3036
collisions:25806 txqueuelen:1000
RX bytes:7446 (7.2 Kb) TX bytes:559247 (546.1 Kb)
Interrupt:20 Base address:0xbf00
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:27 errors:0 dropped:0 overruns:0 frame:0
TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3711 (3.6 Kb) TX bytes:3711 (3.6 Kb)
The router is connecting to the eth1 as they are in the same network.
Make sure you can ping to each other.
ghgv@linux-edfh:~/Escritorio/programs> ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=64 time=0.045 ms
64 bytes from 192.168.2.1: icmp_seq=2 ttl=64 time=0.035 ms
^C
--- 192.168.2.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.035/0.040/0.045/0.005 ms
ghgv@linux-edfh:~/Escritorio/programs> ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
64 bytes from 192.168.2.2: icmp_seq=1 ttl=255 time=4.82 ms
64 bytes from 192.168.2.2: icmp_seq=2 ttl=255 time=2.31 ms
64 bytes from 192.168.2.2: icmp_seq=3 ttl=255 time=2.35 ms
^Z
[1]+ Detenido ping 192.168.2.2
Now, what we need is a program able to send packets in UDP mode (RIP runs on top of UDP) and send a packet.
I found this program that sends a UDP packet over the network. The only important thing is to calculate the pseudo-header of UDP to be able to run it properly. Otherwise, I think the packet does not pass through the linux kernel to be seen by WireShark.
/*
Copyright 2010 Gabriel Serme
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
*/
#include <sys/socket.h>
#include <sys/types.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>
#include <netinet/udp.h>
#include <arpa/inet.h>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define LEN 512
typedef unsigned short u16;
typedef unsigned long u32;
//2nd
unsigned short csum (unsigned short *buf, int nwords);
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf);
int main(int argc, char * argv[])
{
# if __BYTE_ORDER == __LITTLE_ENDIAN //reverse per 8 bits
printf("little endian\n");
#else
printf("big endian\n");
#endif
if(argc != 5)
{
printf("- Usage %s <IP source> <port source> <IP dest> <port dest>\n", argv[0]);
exit(1);
}else{
printf ("Args : \n"
"\tip source : %s:%s\n"
"\tip dest : %s:%s\n",
argv[1], argv[2], argv[3], argv[4]);
}
int PSOURCE = atoi (argv[2]);
int PDEST = atoi(argv[4]);
char *SOURCE = argv[1];
char *DEST = argv[3];
char * ANSWER = argv[5];
int s;
struct sockaddr_in daddr, saddr, answerip;
char packet[LEN];
/* point the iphdr to the beginning of the packet */
struct iphdr *ip = (struct iphdr *)packet;
struct udphdr *udp = (struct udphdr *)((void *) ip + sizeof(struct iphdr));
struct dnshdr *dns = (struct dnshdr *)((void *) udp + sizeof(struct udphdr));
if ((s = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)) < 0) {
perror("error:");
exit(EXIT_FAILURE);
}
daddr.sin_family = AF_INET;
saddr.sin_family = AF_INET;
daddr.sin_port = htons(PDEST);
saddr.sin_port = htons(PSOURCE);
saddr.sin_addr.s_addr=inet_addr("192.168.2.1");
daddr.sin_addr.s_addr=inet_addr("192.168.2.2");
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
//inet_pton(AF_INET, DEST, (struct in_addr *)&daddr.sin_addr);
memset(daddr.sin_zero, 0, sizeof(daddr.sin_zero));
memset(saddr.sin_zero, 0, sizeof(saddr.sin_zero));
memset(udp, 0, sizeof(struct udphdr));
memset(ip, 0, sizeof(struct iphdr));
ip->ihl = 5; //header length
ip->version = 4;
ip->tos = 0x0;
ip->id = 0;
ip->frag_off = htons(0x4000); /* DF */
ip->ttl = 64; /* default value */
ip->protocol = 17; //IPPROTO_RAW; /* protocol at L4 */
ip->check = 0; /* not needed in iphdr */
ip->saddr = saddr.sin_addr.s_addr;
ip->daddr = daddr.sin_addr.s_addr;
udp->source = htons(PSOURCE);
udp->dest = htons (PDEST);
int sizedata = 100;
memset(((void *) udp) + sizeof(struct udphdr), 'S', sizedata);
int sizeudpdata = sizeof(struct udphdr) + sizedata;
ip->tot_len = htons(sizeudpdata + sizeof(struct iphdr)); /* 16 byte value */
udp->len = htons(sizeudpdata);
udp->check = udp_checksum(ip,udp,udp);
printf ("Checksum : 0x%x\n", udp->check);
printf ("Sizes : \n\t[+] iphdr %d"
"\n\t[+] udphdr %d\n",
sizeof(struct iphdr), sizeof(struct udphdr));
printf ("Total size : %d\n", sizeudpdata);
int optval = 1;
if (setsockopt(s, IPPROTO_IP, IP_HDRINCL, &optval, sizeof(int))
< 0)
perror ("IP HDRINCL");
while(1) {
int sizepacket = sizeof(struct iphdr) + sizeudpdata;
if (sendto(s, (char *)packet, sizepacket, 0, (struct sockaddr *)&daddr, (socklen_t)sizeof(daddr)) < 0)
perror("packet send error:");
else
printf("Sent packet\n");
sleep(5);
}
exit(EXIT_SUCCESS);
}
//http://www.linuxquestions.org/questions/linux-networking-3/udp-checksum-algorithm-845618/
//modified by Gabriel Serme
struct pseudo_hdr {
u_int32_t source;
u_int32_t dest;s
u_int8_t zero; //reserved, check http://www.rhyshaden.com/udp.htm
u_int8_t protocol;
u_int16_t udp_length;
};
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf)
{
//take in account padding if necessary
int calculated_length = ntohs(udp->len)%2 == 0 ? ntohs(udp->len) : ntohs(udp->len) + 1;
struct pseudo_hdr ps_hdr = {0};
bzero (&ps_hdr, sizeof(struct pseudo_hdr));
uint8_t data[sizeof(struct pseudo_hdr) + calculated_length];
bzero (data, sizeof(struct pseudo_hdr) + calculated_length );
ps_hdr.source = ip->saddr;
ps_hdr.dest = ip->daddr;
ps_hdr.protocol = IPPROTO_UDP; //17
ps_hdr.udp_length = udp->len;
memcpy(data, &ps_hdr, sizeof(struct pseudo_hdr));
memcpy(data + sizeof(struct pseudo_hdr), buf, ntohs(udp->len) ); //the remaining bytes are set to 0
return csum((uint16_t *)data, sizeof(data)/2);/*
Copyright 2010 Gabriel Serme
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
*/
#include <sys/socket.h>
#include <sys/types.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>
#include <netinet/udp.h>
#include <arpa/inet.h>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define LEN 512
typedef unsigned short u16;
typedef unsigned long u32;
//2nd
unsigned short csum (unsigned short *buf, int nwords);
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf);
int main(int argc, char * argv[])
{
# if __BYTE_ORDER == __LITTLE_ENDIAN //reverse per 8 bits
printf("little endian\n");
#else
printf("big endian\n");
#endif
if(argc != 5)
{
printf("- Usage %s <IP source> <port source> <IP dest> <port dest>\n", argv[0]);
exit(1);
}else{
printf ("Args : \n"
"\tip source : %s:%s\n"
"\tip dest : %s:%s\n",
argv[1], argv[2], argv[3], argv[4]);
}
int PSOURCE = atoi (argv[2]);
int PDEST = atoi(argv[4]);
char *SOURCE = argv[1];
char *DEST = argv[3];
char * ANSWER = argv[5];
int s;
struct sockaddr_in daddr, saddr, answerip;
char packet[LEN];
/* point the iphdr to the beginning of the packet */
struct iphdr *ip = (struct iphdr *)packet;
struct udphdr *udp = (struct udphdr *)((void *) ip + sizeof(struct iphdr));
struct dnshdr *dns = (struct dnshdr *)((void *) udp + sizeof(struct udphdr));
if ((s = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)) < 0) {
perror("error:");
exit(EXIT_FAILURE);
}
daddr.sin_family = AF_INET;
saddr.sin_family = AF_INET;
daddr.sin_port = htons(PDEST);
saddr.sin_port = htons(PSOURCE);
saddr.sin_addr.s_addr=inet_addr("192.168.2.1");
daddr.sin_addr.s_addr=inet_addr("192.168.2.2");
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
//inet_pton(AF_INET, DEST, (struct in_addr *)&daddr.sin_addr);
memset(daddr.sin_zero, 0, sizeof(daddr.sin_zero));
memset(saddr.sin_zero, 0, sizeof(saddr.sin_zero));
memset(udp, 0, sizeof(struct udphdr));
memset(ip, 0, sizeof(struct iphdr));
ip->ihl = 5; //header length
ip->version = 4;
ip->tos = 0x0;
ip->id = 0;
ip->frag_off = htons(0x4000); /* DF */
ip->ttl = 64; /* default value */
ip->protocol = 17; //IPPROTO_RAW; /* protocol at L4 */
ip->check = 0; /* not needed in iphdr */
ip->saddr = saddr.sin_addr.s_addr;
ip->daddr = daddr.sin_addr.s_addr;
udp->source = htons(PSOURCE);
udp->dest = htons (PDEST);
int sizedata = 100;
memset(((void *) udp) + sizeof(struct udphdr), 'S', sizedata);
int sizeudpdata = sizeof(struct udphdr) + sizedata;
ip->tot_len = htons(sizeudpdata + sizeof(struct iphdr)); /* 16 byte value */
udp->len = htons(sizeudpdata);
udp->check = udp_checksum(ip,udp,udp);
printf ("Checksum : 0x%x\n", udp->check);
printf ("Sizes : \n\t[+] iphdr %d"
"\n\t[+] udphdr %d\n",
sizeof(struct iphdr), sizeof(struct udphdr));
printf ("Total size : %d\n", sizeudpdata);
int optval = 1;
if (setsockopt(s, IPPROTO_IP, IP_HDRINCL, &optval, sizeof(int))
< 0)
perror ("IP HDRINCL");
while(1) {
int sizepacket = sizeof(struct iphdr) + sizeudpdata;
if (sendto(s, (char *)packet, sizepacket, 0, (struct sockaddr *)&daddr, (socklen_t)sizeof(daddr)) < 0)
perror("packet send error:");
else
printf("Sent packet\n");
sleep(5);
}
exit(EXIT_SUCCESS);
}
//http://www.linuxquestions.org/questions/linux-networking-3/udp-checksum-algorithm-845618/
//modified by Gabriel Serme
struct pseudo_hdr {
u_int32_t source;
u_int32_t dest;
u_int8_t zero; //reserved, check http://www.rhyshaden.com/udp.htm
u_int8_t protocol;
u_int16_t udp_length;
};
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf)
{
//take in account padding if necessary
int calculated_length = ntohs(udp->len)%2 == 0 ? ntohs(udp->len) : ntohs(udp->len) + 1;
struct pseudo_hdr ps_hdr = {0};
bzero (&ps_hdr, sizeof(struct pseudo_hdr));
uint8_t data[sizeof(struct pseudo_hdr) + calculated_length];
bzero (data, sizeof(struct pseudo_hdr) + calculated_length );
ps_hdr.source = ip->saddr;
ps_hdr.dest = ip->daddr;
ps_hdr.protocol = IPPROTO_UDP; //17
ps_hdr.udp_length = udp->len;
memcpy(data, &ps_hdr, sizeof(struct pseudo_hdr));
memcpy(data + sizeof(struct pseudo_hdr), buf, ntohs(udp->len) ); //the remaining bytes are set to 0
return csum((uint16_t *)data, sizeof(data)/2);
}
/* Not my code */
unsigned short csum (unsigned short *buf, int nwords)
{/*
Copyright 2010 Gabriel Serme
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
*/
#include <sys/socket.h>
#include <sys/types.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>
#include <netinet/udp.h>
#include <arpa/inet.h>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define LEN 512
typedef unsigned short u16;
typedef unsigned long u32;
//2nd
unsigned short csum (unsigned short *buf, int nwords);
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf);
int main(int argc, char * argv[])
{
# if __BYTE_ORDER == __LITTLE_ENDIAN //reverse per 8 bits
printf("little endian\n");
#else
printf("big endian\n");
#endif
if(argc != 5)
{
printf("- Usage %s <IP source> <port source> <IP dest> <port dest>\n", argv[0]);
exit(1);
}else{
printf ("Args : \n"
"\tip source : %s:%s\n"
"\tip dest : %s:%s\n",
argv[1], argv[2], argv[3], argv[4]);
}
int PSOURCE = atoi (argv[2]);
int PDEST = atoi(argv[4]);
char *SOURCE = argv[1];
char *DEST = argv[3];
char * ANSWER = argv[5];
int s;
struct sockaddr_in daddr, saddr, answerip;
char packet[LEN];
/* point the iphdr to the beginning of the packet */
struct iphdr *ip = (struct iphdr *)packet;
struct udphdr *udp = (struct udphdr *)((void *) ip + sizeof(struct iphdr));
struct dnshdr *dns = (struct dnshdr *)((void *) udp + sizeof(struct udphdr));
if ((s = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)) < 0) {
perror("error:");
exit(EXIT_FAILURE);
}
daddr.sin_family = AF_INET;
saddr.sin_family = AF_INET;
daddr.sin_port = htons(PDEST);
saddr.sin_port = htons(PSOURCE);
saddr.sin_addr.s_addr=inet_addr("192.168.2.1");
daddr.sin_addr.s_addr=inet_addr("192.168.2.2");
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
//inet_pton(AF_INET, DEST, (struct in_addr *)&daddr.sin_addr);
memset(daddr.sin_zero, 0, sizeof(daddr.sin_zero));
memset(saddr.sin_zero, 0, sizeof(saddr.sin_zero));
memset(udp, 0, sizeof(struct udphdr));
memset(ip, 0, sizeof(struct iphdr));
ip->ihl = 5; //header length
ip->version = 4;
ip->tos = 0x0;
ip->id = 0;
ip->frag_off = htons(0x4000); /* DF */
ip->ttl = 64; /* default value */
ip->protocol = 17; //IPPROTO_RAW; /* protocol at L4 */
ip->check = 0; /* not needed in iphdr */
ip->saddr = saddr.sin_addr.s_addr;
ip->daddr = daddr.sin_addr.s_addr;
udp->source = htons(PSOURCE);
udp->dest = htons (PDEST);
int sizedata = 100;
memset(((void *) udp) + sizeof(struct udphdr), 'S', sizedata);
int sizeudpdata = sizeof(struct udphdr) + sizedata;
ip->tot_len = htons(sizeudpdata + sizeof(struct iphdr)); /* 16 byte value */
udp->len = htons(sizeudpdata);
udp->check = udp_checksum(ip,udp,udp);
printf ("Checksum : 0x%x\n", udp->check);
printf ("Sizes : \n\t[+] iphdr %d"
"\n\t[+] udphdr %d\n",
sizeof(struct iphdr), sizeof(struct udphdr));
printf ("Total size : %d\n", sizeudpdata);
int optval = 1;
if (setsockopt(s, IPPROTO_IP, IP_HDRINCL, &optval, sizeof(int))
< 0)
perror ("IP HDRINCL");
while(1) {
int sizepacket = sizeof(struct iphdr) + sizeudpdata;
if (sendto(s, (char *)packet, sizepacket, 0, (struct sockaddr *)&daddr, (socklen_t)sizeof(daddr)) < 0)
perror("packet send error:");
else
printf("Sent packet\n");
sleep(5);
}
exit(EXIT_SUCCESS);
}
//http://www.linuxquestions.org/questions/linux-networking-3/udp-checksum-algorithm-845618/
//modified by Gabriel Serme
struct pseudo_hdr {
u_int32_t source;
u_int32_t dest;
u_int8_t zero; //reserved, check http://www.rhyshaden.com/udp.htm
u_int8_t protocol;
u_int16_t udp_length;
};
uint16_t udp_checksum(const struct iphdr *ip,
const struct udphdr *udp,
const uint16_t *buf)
{
//take in account padding if necessary
int calculated_length = ntohs(udp->len)%2 == 0 ? ntohs(udp->len) : ntohs(udp->len) + 1;
struct pseudo_hdr ps_hdr = {0};
bzero (&ps_hdr, sizeof(struct pseudo_hdr));
uint8_t data[sizeof(struct pseudo_hdr) + calculated_length];
bzero (data, sizeof(struct pseudo_hdr) + calculated_length );
ps_hdr.source = ip->saddr;
ps_hdr.dest = ip->daddr;
ps_hdr.protocol = IPPROTO_UDP; //17
ps_hdr.udp_length = udp->len;
memcpy(data, &ps_hdr, sizeof(struct pseudo_hdr));
memcpy(data + sizeof(struct pseudo_hdr), buf, ntohs(udp->len) ); //the remaining bytes are set to 0
return csum((uint16_t *)data, sizeof(data)/2);
}
/* Not my code */
unsigned short csum (unsigned short *buf, int nwords)
{
unsigned long sum;
for (sum = 0; nwords > 0; nwords--)
sum += *buf++;
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >> 16);
return ~sum;
}
unsigned long sum;
for (sum = 0; nwords > 0; nwords--)
sum += *buf++;
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >> 16);
return ~sum;
}
}
/* Not my code */
unsigned short csum (unsigned short *buf, int nwords)
{
unsigned long sum;
for (sum = 0; nwords > 0; nwords--)
sum += *buf++;
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >> 16);
return ~sum;
}
I am writing the IP source and destination addresses directly. I do not know why the
//inet_pton(AF_INET, SOURCE, (struct in_addr *)&saddr.sin_addr);
sets the wrong destination address. Anyway, I get:
You can see that the archive is made up os "S"s. So, it is not useful at this point but we will improve it. So that we can send a RIP packet.
Suscribirse a:
Entradas (Atom)